aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorAUTOMATIC1111 <16777216c@gmail.com>2023-05-18 10:12:17 +0300
committerGitHub <noreply@github.com>2023-05-18 10:12:17 +0300
commit182330ae40c93b761fced8d03bbdd8523f1739d0 (patch)
treec95f2e531cc34475eb39266add6d12a2a5e1e2b3 /pyproject.toml
parent0d31f20cbd556ea4ba3d8ad9254bcce71c32088c (diff)
parent983f2c494ad8fed2f08193681ba0bf5dda01555a (diff)
Merge branch 'dev' into ngrok-py
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml32
1 files changed, 32 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 00000000..d4a1bbf4
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,32 @@
+[tool.ruff]
+
+target-version = "py39"
+
+extend-select = [
+ "B",
+ "C",
+ "I",
+ "W",
+]
+
+exclude = [
+ "extensions",
+ "extensions-disabled",
+]
+
+ignore = [
+ "E501", # Line too long
+ "E731", # Do not assign a `lambda` expression, use a `def`
+
+ "I001", # Import block is un-sorted or un-formatted
+ "C901", # Function is too complex
+ "C408", # Rewrite as a literal
+ "W605", # invalid escape sequence, messes with some docstrings
+]
+
+[tool.ruff.per-file-ignores]
+"webui.py" = ["E402"] # Module level import not at top of file
+
+[tool.ruff.flake8-bugbear]
+# Allow default arguments like, e.g., `data: List[str] = fastapi.Query(None)`.
+extend-immutable-calls = ["fastapi.Depends", "fastapi.security.HTTPBasic"]