aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorAUTOMATIC <16777216c@gmail.com>2023-05-10 11:00:07 +0300
committerAUTOMATIC <16777216c@gmail.com>2023-05-10 11:00:07 +0300
commite42de4b8a2356c6d286adb07292442d75e5595d3 (patch)
tree73451e62385de1478ac0d449b161069f2fafec21 /pyproject.toml
parent57ef617251a5cb118fb5a49c6e7cd2b609323ab0 (diff)
update ruff config with more stuff
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml14
1 files changed, 13 insertions, 1 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 24f5b1ae..2f65fd6c 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,12 @@
[tool.ruff]
-target-version = "py310"
+target-version = "py39"
+
+extend-select = [
+ "B",
+ "C",
+ "I",
+]
exclude = [
"extensions",
@@ -10,6 +16,12 @@ exclude = [
ignore = [
"E501", # Line too long
"E731", # Do not assign a `lambda` expression, use a `def`
+
+ "I001", # Import block is un-sorted or un-formatted
+ "C901", # Function is too complex
+ "C408", # Rewrite as a literal
+ "B007", # Loop control variable not used within loop body
+
]